Unusually high and slow email queues.
Incident Report for Assemble
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 13:01 GMT
Update
The queue has now been fully processed and the additional resources will stay online until the root cause for the backlog is found. Emails should be delivered instantly now.

If you had previously requested your authentication code to log in, you can now successfully request this again.
Posted Nov 22, 2021 - 12:39 GMT
Update
Extra resources have been brought online and the queues are going down faster now.
Posted Nov 22, 2021 - 12:20 GMT
Investigating
We are currently experiencing unusually high and slow email queues. The team are now looking into this and hope to bring services back to normal as soon as we can.
Posted Nov 22, 2021 - 12:00 GMT
This incident affected: Outbound Email Service.