Intermittent performance issues
Incident Report for Assemble
Resolved
This has now been resolved
Posted May 25, 2023 - 18:09 BST
Monitoring
Due to an increased number of connections we were hitting high CPU usage on database cluster. We have lowered the number of internally made connections and CPU usage has returned to normal.

We will continue to monitor this.
Posted May 25, 2023 - 17:00 BST
Investigating
We are aware of some intermittent performance issues with Assemble. Our engineers are actively working on this.
Posted May 25, 2023 - 16:15 BST
This incident affected: API and Assemble Web App.